Test Sending E-mails to Subscribers

Incident Report for Presslabs

Resolved

This incident has been resolved.
Posted Jul 27, 2021 - 20:27 EEST

Investigating

This is a test e-mail to check if e-mails are sent to subscribers.
Posted Jul 27, 2021 - 20:26 EEST
This incident affected: Email delivery.