Gutenberg meta boxes overlap in Chrome 77
Incident Report for Presslabs
Resolved
We have prepared a patch for this bug, and it will be deployed on Monday alongside the WP 5.2.3 update. A maintenance window will be announced shortly.
Posted Sep 13, 2019 - 18:11 EEST
Identified
A bug was recently reported inside the Gutenberg editor which is affecting Chrome 77 users while editing pages and posts. We'll be trying to add a workaround for this until the official fix will be released.

More details about this bug can be found here: https://github.com/WordPress/gutenberg/issues/17406
Posted Sep 12, 2019 - 10:44 EEST