WordPress transactional e-mails not being sent

Incident Report for Presslabs

Resolved

Our SendGrid account has been reconnected and multiple measures were taken to avoid this from happening in the future. Thanks for your patience and understanding of this unforeseen incident.
Posted May 16, 2024 - 16:00 EEST

Identified

We have been informed that the e-mails issued through WordPress are not being sent. Upon investigating, we discovered that our SendGrid account has been suspended, and we are working with them to unblock our account. We'll post updates here as soon as we have them.
Posted May 15, 2024 - 23:29 EEST
This incident affected: Email delivery.