Unable to login to Presslabs Dashboard
Incident Report for Presslabs
Resolved
This is now resolved, thank you for your patience!
Posted 10 months ago. Jun 28, 2018 - 21:42 EEST
Investigating
We are investigating why users cannot login to our dashboard. We'll send updates here as soon as we have them. For any urgent actions that you need to accomplish from our dashboard, please e-mail us to support@presslabs.com. Thank you!
Posted 10 months ago. Jun 28, 2018 - 21:25 EEST
This incident affected: Presslabs Dashboard.