Partial outage of Presslabs Dashboard this morning
Incident Report for Presslabs
Resolved
This incident has been resolved.
Posted Jan 15, 2018 - 10:55 EET
Identified
Our dashboard is currently down. We are working to get it back up ASAP. No other service is affected.
Posted Jan 15, 2018 - 09:52 EET